You must be registered to use and view the SEARCH and full board access!

Ford F-150 2009 AC Control Issue ( PX6)

All general discussions related to Phoenix Android Radio head units goes here.
Post Reply
Marcel de Manager
Posts: 1
Joined: Mon Apr 11, 2022 3:37 am

Ford F-150 2009 AC Control Issue ( PX6)

Post by Marcel de Manager »

Klein3
Klein3 (207.62 KiB) Viewed 11097 times
Klein2
Klein2 (203.8 KiB) Viewed 11097 times
Klein1
Klein1 (151.15 KiB) Viewed 11097 times
Hi Fellow Tech Users,

I have a problem with my AC and I have NO clue. I hope I can get some from you guys.

The problem:
-I CAN control everything heated seats, heater, blower etc. But I can NOT control the AC. When I turn it on it wont turn on the AC. If I put the OEM unit on the AC works perfectly. It does not make any sense.

-Ive tried to get into the baudrate en canbus settings to try to change the settings as ive read on the internet. But I cant. Ive attatched some pictures to give more info about my set up.

The setup:

-Ford F150 (2009)
-PX6
-It runs ons android 9 as you can see in the pictures

A penny for your thoughts!

:D
BenLXc
Posts: 1
Joined: Fri Feb 10, 2023 8:48 pm

Re: Ford F-150 2009 AC Control Issue ( PX6)

Post by BenLXc »

Just curious did you ever figure this out? I have a similar issue with my 2011 running android 10
John.Manning
Posts: 2
Joined: Sat Feb 18, 2023 9:41 am

Re: Ford F-150 2009 AC Control Issue ( PX6)

Post by John.Manning »

I have 2011 f150, keep radio, manual AC... similar issue. AC freezing up, lose air flow. Stock controls work fine
Last edited by John.Manning on Sat Feb 18, 2023 9:56 am, edited 1 time in total.
John.Manning
Posts: 2
Joined: Sat Feb 18, 2023 9:41 am

Re: Ford F-150 2009 AC Control Issue ( PX6)

Post by John.Manning »

BenLXc wrote: Fri Feb 10, 2023 8:56 pm Just curious did you ever figure this out? I have a similar issue with my 2011 running android 10
I have the same 2011 with android 10. I had other issues, they sent me canbus update and I used 2012 F150 Keep All..
I still have the stock stereo and had manual AC controls.
Almost everything works now except the AC freezes up after a while and I lose air flow.
Stock controls work perfect no AC issues with my old system.

I see people messing with baud rates? Not sure if that applies here... any suggestions?
By the way I can fwd you the email from them with the canbus update and android 10 firmware update if you want?
John.Manning.Jr@gmail.com
Last edited by John.Manning on Sat Feb 18, 2023 9:55 am, edited 1 time in total.
Post Reply