1. steve
  2. General Discussion
  3. Friday, 07 February 2020

I have an '07 Lexus GS, and after upgrading my PX6 to 8.1, the display no longer works.  I ran the update, after rebooting, it showed the BIOS screen and said the install was successful.  It said to remove the USB, which I did.  Then the system rebooted again and went black.  I waited and waited, but nothing came on the display.

I can see the backlight on in the back and my bluetooth connects (presumably after it boots up), and my A/C buttons still work.  However, the display does not show anything other than a black screen.  I believe the touch screen also is not working as nothing seems to respond.  The steering wheel buttons don't seem to do anything either.  I tried pressing the RST button briefly, as well as tried holding it down for 30 seconds multiple times.  I also turned the car off/on several times, but I still have a black screen.

How can I go about getting my PX6 working again?  Can I roll back my software to the factory version? Any help would be appreciated!  Thanks!



Accepted Answer Pending Moderation
0
Votes
Undo

I have the same Problem if u find some solution, please contact to me This email address is being protected from spambots. You need JavaScript enabled to view it. and if i find i Will contact to you thanks

  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!