1. MidniteAvenger
  2. Ford
  3. Friday, 14 June 2019

My car has the Phoenix 12.1 Android PX3 radio in it. It was working fine up until a couple days ago. So originally all the AC controls worked fine. Then I shut the car off and turned in for the night. Come out the next morning and the fan is still blowing on low and the AC is on, not now there is no indication of fan speed or temperature on the screen and pressing the buttons changes nothing. I can still turn the AC on and off and control the defrost vents, but no fan speed or temp. Any ideas? I believe this problem to be software related since all the other Canbus features appear to be working fine. Is there a firmware/MCU/app update I can do to try and reinstall the AC controls portion of the radio? Or does anyone have any other ideas? Before anyone asks, yes I've tried changing the settings as suggested on Phoenix's website. No change. I can post pictures of my System info screen and what my AC controls look like.IMG 2083IMG 2083



Accepted Answer Pending Moderation
0
Votes
Undo

Midnite--what is the car type set too?  Also what is your canbus and airbix bus settings?

  1. 4 weeks ago
  2. Ford
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!